Menú Cerrar

Actualización en la plataforma de SAT

El gobierno en México con la ayuda de las nuevas tecnologías de información entro en la era en la cual la mayoría de personas sobre todo empresarios o dueños de negocios tenían acceso a internet lo cual se propuso a implementar e invertir recursos para llevar la administración de la recaudación de impuestos mas ágil y mas sencilla, algo que cuando se implemento muchos contribuyentes les costo mucho adaptarse sobre todo para los contadores que mejor preferían todo manual sin embargo ya con la inversión puesta en el sistema y nueva metodología pues ya no había marcha atrás y sin embargo se ha ido mejorando ademas de actualizar las implementaciones.

SAT

El problema que quiero plantear aquí es sobre el software que tiene este sistema y es que como muchos sabrán hay que instalar este “plugin” para poder utilizar el sistema web y tramitar lo necesario como por ejemplo realizar las facturas electrónicas, consulta de información, DIOT, entre otros. El problema no es tanto la funcionalidad ya que si se cumple con los requisitos para su buen funcionamiento y hace el trabajo, esa parte no la quiero criticar, lo que quiero explicar es la tecnología mezclada que existe ya que requiere tanto del famosos “plugin o complemento” de Java y Silverlight los cuales a veces son un fastidio para las actualizaciones y un usuario sin querer puede actualizarlo y las configuraciones que tenia cambian y hay que volver a realizarlas, a veces se traban y hay que reiniciar todas nuestras operaciones o hay dificultades con el sistema operativo.

Todo ese listado y mas lo pongo asi ya que esta mezcla de tecnologías y configuraciones aburren al usuario sin embargo ya se tiene que realizar para poder ante SAT realizar nuestros movimientos y me incluyo ya que utilizo el sistema como contribuyente y me causa dolor de cabeza ademas de que doy soporte a varios usuarios en diferentes empresas sobre esto y de repente hasta es confuso.

Por otra parte, sabemos que se utiliza un navegador web para accesar a este sistema y algo muy común ya para poder realizar estas transacciones pero la seguridad cuenta mucho, no solo estando en internet, sabemos que podemos ser victimas de robo de identidad, nuestros datos pueden ser interceptados para robo de información y es ahí donde estos “plugins” hacen retomar una advertencia que hace años salio a la luz, una advertencia de seguridad que en estos tiempos no se ha podido detener y es que los desarrolladores de estos plugins como Oracle que desarrolla Java, Adobe que desarrolla FlasPlayer, Microsoft que desarrolla Silverlight entre otros no aseguraron estos programas y hoy en día se ha retomado el tema ya que los navegadores web van a dar por terminado su soporte a ellos como ya es el caso de Google Chrome el navegador desarrollado por Google que ya omitió en sus actualizaciones el funcionamiento del plugin Java, y menciono este navegador ya que a pesar de ser popular (aunque en lo personal no lo recomiendo usar) fue el primero en tomar cartas en el asunto ya que las vulnerabilidades que se encontraban en su navegador venían de los plugin como Java, FlashPlayer y Silverlight afectando a miles de usuarios que a través de este navegador sufrían de algún ataque a su sistema como el robo de la información que procesaba en ese instante, control remoto del equipo, plantación de virus y seguimiento de sus actividades realizadas en internet.

Ahora bien, ¿Que tienen que ver estos complementos o plugins al tema con el sistema de gobierno o mas bien, los sistemas desarrollados para el gobierno?. Muy fácil, funcionan con estos plugins, y al funcionar con ellos existe inseguridad en nuestras transacciones ya antes mencionadas y que ademas nos afectara a muchos contribuyentes siendo que cuando decidan cancelar estas actualizaciones en navegadores no tendremos sistema o tendremos que esperar a actualizar nuestro navegador sin embargo causar problemas, y no solo es la pagina del SAT, si no también afectara a la de IMSS sobre todo con la aplicación IDSE, ya que requiere de configuración y total aceptación de este complemento de Java para su funcionamiento. Yo por mi parte tuve una platica por chat con el servicio de soporte informático en el cual planteaba esta situación y solo me dijeron que utilizara otros navegadores ya que en Chrome se esta pasando por esta situación, lo cual por ahorita afecto a muchos usuarios con este navegador y pasara que también cuando los demás navegadores impongan esto nos quedaremos sin realizar las funciones que hacíamos y lo mas preocupante es que en las dependencias de gobierno no se están tomando estas medidas, no se esta realizando un trabajo para actualizar su sistema y que al momento que como indica el blog oficial de Oracle y muchos medios de comunicación en la rama de la informática no darán aviso, solo se esta estandarizando y por ende ya advertidos a muchos desarrolladores que busquen otra solución ya esta dado el aviso desde antes, a la mera hora querrán hacer cambios y se sufrirá de una incertidumbre para esta situación de como lo solucionaran ya que muchos estamos ya apegados al sistema y es quien nos resuelve la situación fiscal.

Las fuentes oficiales como Google comentan que tomaron esta medida tras la inseguridad que se vivía con los usuarios a través de estos complementos y los llaman riesgos de seguridad, el blog oficial de Oracle comenta por su parte que esta medida se tomo e informo desde 2004 para prevenir a todos los desarrolladores que migraran sus complementos a otras alternativas pero como verán al gobierno de México no le preocupa eso, y cuando llegue la hora hasta impuestos por actualizaciones saldrán pagados por los contribuyentes.

La seguridad informática se toma muy enserio y es algo que no se debe de dejar pasar, por ello estas empresas están de acuerdo con que ya no  son eficientes estos complementos que se requieren ya que ni los desarrolladores de ellos han podido frenarlo, ojala que el SAT, el IMSS y las demás dependencias que tienen desarrollos de este tipo tomen medidas lo antes posibles para que no ocurra algo inesperado en el sistema y se invierta en un sistema homogéneo el cual no dependa de otros sistemitas para su función ademas de que así se podrá realizar en multiplataforma tanto en sistemas operativos, navegadores web, dispositivos entre otros.

Fuentes:

  • https://www.java.com/es/download/faq/chrome.xml
  • https://support.google.com/chrome/answer/6213033?hl=es
  • https://blogs.oracle.com/java-platform-group/entry/npapi_plugin_perspectives_and_the
  • https://developer.mozilla.org/en-US/Add-ons/Plugins

Chat con el SAT

Gracias por esperar en la línea, le comento que para utilizar el portal del SAT se recomienda Internet Explorer 8 o superior, Firefox 30 ó superior, Google Chrome 27 o superior (Excepto versión 42 o superior ya que no ejecuta java), Safari 6.1 ó superior.

Publicado en Comentarios, Experiencia, Java, Seguridad Informatica